1. Hey Guest Did you know you can win an Honor 10 phone worth ₹33,000 and an additional ₹70,000 in paytm vouchers, just by replying to some threads and taking part in the discussions happening in the Honor Hub?

    What are you waiting for? Start commenting and start winning! Remember to read the instructions posted here.

    Dismiss Notice

How to mount NTFS partition in Ubuntu

Discussion in 'Open Source' started by Desmond David, May 9, 2006.

Thread Status:
Not open for further replies.
  1. Desmond David

    Desmond David Destroy Erase Improve

    Joined:
    Apr 9, 2005
    Messages:
    5,961
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Pune
    I have installed Ubuntu the Warty Warthog release. My problem is that I cannot mount my NTFS (hda1) partition for myself. I made a folder from my username, and mounted the partition by using SU. Now, I do not have permission to view the partition. I always have to log in as SU to view the files.

    Please Help.
     
  2. paragkalra

    paragkalra The Linux Man !

    Joined:
    Jan 6, 2006
    Messages:
    217
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Nagpur, Maharashtra, India
  3. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Well you can mount ntfs as read-only partition. Add the following in /etc/fstab to mount it and view without su'ing.
    Code:
    /dev/hdx  /<name of the folder>   ntfs   defaults,ro,umask=000    0  0
    
    Here x in hdx is the partition number of the ntfs partition. If you have SATA drive you have to use sdx.
    And reboot the computer. Somehow it did not work for me without rebooting.
     
  4. OP
    OP
    Desmond David

    Desmond David Destroy Erase Improve

    Joined:
    Apr 9, 2005
    Messages:
    5,961
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Pune
    Tried but still I have to switch to su to view it.
     
  5. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    su in ubuntu???
    Please explain what have you done and have you rebooted after making changes?
     
  6. OP
    OP
    Desmond David

    Desmond David Destroy Erase Improve

    Joined:
    Apr 9, 2005
    Messages:
    5,961
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Pune
    Yes, I made changes to /etc/fstab as you have described exactly, even counted the spaces and entered the lines. I then restarted and tried to get into the /mnt/win folder, where I have it mounted, then it says that I donot have permission. I swear I entered everything correctly.
     
  7. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Again did you reboot befotre trying to access the partition after you made changes? And no need to count the number of spaces I have left it does not make a difference. You just need to leave a space.
    It won't work without a reboot. That had happened to me too. Me and some others were puliing out our hair at why I could not access windows partition as normal user even after making changes in fstab. But, it went all fine after the next reboot.
     
  8. bizzare_blue

    bizzare_blue New Member

    Joined:
    Aug 8, 2004
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lucknow
    Ain't it possible to have "write-access" to NTFS partitions from ubuntu?
     
  9. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Well it is possible using ntfs-3g or ntfs-static but it will be too slow. It is so slow that I found it too irritating to even use it.
     
  10. QwertyManiac

    QwertyManiac Commander in Chief

    Joined:
    Jul 17, 2005
    Messages:
    6,656
    Likes Received:
    10
    Trophy Points:
    0
    ^^
    NTFS-3G isnt slow at all tech_your_future!
    Here, follow this for those who need NTFS-3g in Ubuntu.
    http://ubuntuforums.org/showthread.php?t=217009
    __________
    are yaar, he said he rebooted. I mounted NTFS in my /media folder and it worked, maybe /mnt/win isnt open to all groups ? Thats a bit weird though.
     
    Last edited: Dec 6, 2006
  11. Desi-Tek.com

    Desi-Tek.com New Member

    Joined:
    Oct 15, 2006
    Messages:
    370
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Mumbai
    i never mounted ntfs partition on ubuntu but i don't know how it mounted windows partition automatically! it allow me to read write on ntfs drive without any problem.
     
  12. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Which version of Ubuntu are you talking about Desi-Tek? It must be Edgy cos AFAIK, ntfs write is supported only since kernel 2.6.17.
     
  13. QwertyManiac

    QwertyManiac Commander in Chief

    Joined:
    Jul 17, 2005
    Messages:
    6,656
    Likes Received:
    10
    Trophy Points:
    0
    Edgy too by default doesnt allow writing to NTFS. But in coming mid summer the k-mod plugin will start write support. :)
     
  14. Desi-Tek.com

    Desi-Tek.com New Member

    Joined:
    Oct 15, 2006
    Messages:
    370
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Mumbai
    @tech_your_future hi mate i am using dapper with latest version of kernel which i compiled recently .It require root permission to to write any thing on ntfs drive .
     
  15. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    OK so that's why. You have compiled a kernel with ntfs write support. A default install of Dapper won't allow to write to ntfs.
    And you should be able to write as non-root user too. I guess module isn't loaded or you may have not set write permissions for non-root user, maybe intentionally.
     
  16. Desi-Tek.com

    Desi-Tek.com New Member

    Joined:
    Oct 15, 2006
    Messages:
    370
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Mumbai
    latest kernel is not the reason i am able to read/write in ntfs drive from the very first day when i installed ubuntu for first time. even through live cd.
    actually i mounted ntfs drive through system>administration>>disks
    than i created a folder called /ntfs/windows
    than i selected partition 1 added this access path /ntfs/windows
    and than i clicked on enable it mounted ntfs drive with read and write support :)
     
  17. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Not possible AFAIK dapper doesn't support writing to ntfs.
     
  18. Desi-Tek.com

    Desi-Tek.com New Member

    Joined:
    Oct 15, 2006
    Messages:
    370
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Mumbai
    i have no idea how it is working for me
     
  19. QwertyManiac

    QwertyManiac Commander in Chief

    Joined:
    Jul 17, 2005
    Messages:
    6,656
    Likes Received:
    10
    Trophy Points:
    0
    The Live CD will definitely not support writing of NTFS. If you compiled a kernel, good job. :D
     
  20. Desi-Tek.com

    Desi-Tek.com New Member

    Joined:
    Oct 15, 2006
    Messages:
    370
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Mumbai
    i am using fully cr@ckd mce xp may be that could be the reason? :)
    @QwertyManiac it took me more than 1.5hour to compile source code of kernel. but it was really fun :)
     
Thread Status:
Not open for further replies.

Share This Page