1. Hey Guest Did you know you can win an Honor 10 phone worth ₹33,000 and an additional ₹70,000 in paytm vouchers, just by replying to some threads and taking part in the discussions happening in the Honor Hub?

    What are you waiting for? Start commenting and start winning! Remember to read the instructions posted here.

    Dismiss Notice

How to? : Install IP Messenger in linux

Discussion in 'Open Source' started by abhijeetanand, Feb 24, 2006.

Thread Status:
Not open for further replies.
  1. abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Please some one give me a detailed description of how to install IP messenger under linux for the gnome
    I downloaded the file for gipmsgr-0.4.0beta1.tar.gz
    unpacked it
    but do not know how to take it a step further
    the configure script when runs returns an error at the end that gtk not installed
    but i have it installed somewhere
    I use Fedora Core 4 on an intel platform p4 3ghz
    please help me.


    thanking you all
     
  2. desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    I dont know what this stuff is. As from your query, you need gtk (probably gtk+-1.2, not gtk+-2.x). So install gtk+1.2 from your installation disk.

    Also if you can post the output of ./configure, that'll be much helpful.
     
  3. OP
    OP
    abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    This basically a software to chat and send n recieve files over the LAN
    I basically used the 32 bit version under win xp
    but now am fed up with XP and am transitioning all of my work to linux
    and we use this software to send msgs and share files..
    please see to it

    This is what I get as the output after running the ./configure script
    I have one more problem but that will be related to Networking and proxies and firewallls
    hope you dont mind answering it here
    Its like am in an university
    and that we access our internet through lan
    but at first we have to log on to cyberoam corporate client
    so i want to know if I can some how bypass this cyberoam thing cause our net is 24 hr dedicated 2mbps broadband connection
    i think you must have got the point
    please help me to bypass this proxy or firewall whatever you call it
    may be port forwarding help me, but am not much sure of it

    thanking you very much

    Abhijeet Anand[/quote]
     
  4. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    As Desertwind told get gtk1.2 installed from Fedora Core 4 Disk.(rpm -ivh xxx.rpm).Also get gtk+-devel-1.2 rpm installed.Or if You have already installed may be should check the env variable set properly.
     
  5. OP
    OP
    abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    but I have this GIMP installed in my pc, and as far as I know it uses gtk
    so doesn't that mean that gtk is preinstalled in my PC...
    yet neways can you tell me how to check wether gtk is there in my pc or not, and if so, then how to set the environment variables
    I am a bit new to it......
    do i use the command 'set' under console
    and by the way which variable is to be set for that..

    thanks for replying.....
     
  6. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    you can query rpmdb as
    Code:
    rpm -qa gtk1.2*
    I believe Ur problem lies with U not installed gtk1.2-dev rpm.so check ur Discs to find this rpm and install it.
     
  7. ujjwal

    ujjwal New Member

    Joined:
    Dec 1, 2003
    Messages:
    780
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    There are two branches of GTK - The GTK1 branch, needed by this software and used by old versions of GIMP, and the GTK2 branch, which is installed on your system (and used by the new GIMP 2.x). The two are not compatible, and so you need to install the GTK1 package as well.

    However, on going through the site, I think this software uses the old Gnome1 libraries as well, which will be a pain for you to install. I recommend using XIP messenger or gtkip messenger instead (XIP will not even require gtk1 to be present)
     
  8. OP
    OP
    abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Ok
    i will try first installing the GTk 1.2 and then try again installing the gip messenger..

    @ujjwal
    but buddy do you think this xipmessenger will work under gnome....

    neways guys
    i am really thankfull to you all people..
    i will post my results as soon as possible....
    within a day...
    and please one more favout I need,,
    please see to my 2nd problem as posted in my 2nd reply

    thanks again...
    c u all
     
  9. OP
    OP
    abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi guys sorry to tell but nothing of that helped me to install gipmsgr or the xip messenger
    i will post outputs tomorrow
    cause write now i am posting this message under windows...

    thanks again

    can nebody tell where is it going wrong
    or is it so because i am having fedora core 4 as my distro
     
  10. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    buddy,have gtk1.2-dev library installed.it will solve the problem.
     
  11. OP
    OP
    abhijeetanand

    abhijeetanand New Member

    Joined:
    Feb 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi there guys
    I tried just everything but nothing seems to help me
    sp now i am giving up this installation at least on Fedora Core 4
    I will try it once more once I have installed some another distro of linux may be mandrake or SuSE.... oe debian
    cause one of my friends was able to install the XIP messenger on debian

    any ways

    thanks once again to all of you to give your time to my problem

    but still
    there's one thing to be solved
    please see my second post and see the second problem in it, just after the quoted text

    bye
    thanks[/b]
     
Thread Status:
Not open for further replies.

Share This Page