Help! Unable to use Oracle 8i in Windows XP

Not open for further replies.

I have a P4 2.4HT processor based machine, 512 MB RAM and 80 GB Hard Drive. I run Windows XP SP2 and Fedora Core-2 Linux as my operating systems. I tried to Install Oracle 8i (version for Windows NT on my system. Installation went smoothly and after that i tried accessing the database using a Visual Basic Application of mine, it worked fine.

But after restarting my system, the oracle instance service shows status as starting, though it never starts. In task manager, oracle.exe is always running. I tried changing the log on account settings of the service. By default it starts using the local SYSTEM account. I tried local service and network service accounnt. It starts successfully then, but the service is still not available. On trying to connect it returns error "tns protocol error."

I tried reinstalling oracle but same thing happened again, as i described above. I tried reinstalling windows xp and installed oracle in a clean environment, but faced same problem again.

Can anyone help?



Cyborg Agent
It might have to do with you TNS Listener. Oracle db itself starting alone will not be enough. You will need the Listener to start as well. See if the listener has started. And also as far as I can remem 8i is not supported on Windows XP. I would suggest either the 9i DB or the 10g DB.

Also try this. If you Oracle client and the Oracle server are on the same machine then you dont need the Listener to be on. So login to the Oracle client with just the user/pass dont give the listerner name and see if that works. If that doesnt then mostly it means that u will have to use 9i or 10g
Not open for further replies.
Top Bottom