• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Harddisk sectors

Status
Not open for further replies.

Ishan

In the zone
I suppose my friends harddisk is corrupted!

When i run Ubuntu livecd in his PC for running fdisk in it for partitioning....

when i gave 'fdisk /dev/hda' command and then 'p' for printing the harddisk's partition table..... it showed no partion in that on ly the headers

so i tried creating a now partion using 'n'
as it asked me i created new primary partion starting from sector 63 to som 10**7...i dont remember exactly but it was the default values it showed

now after creating partion when i pressed 'p' for printing the partion table.. it showed me the first /dev/hda1 partion with default sector size which i entered.. BUT BELOW that it was written in note: " partion 1 is crossing the sector limit" or something like that.

without giving it importance... i tried to save the partions by commeang 'w' but it gave me error "unable to write /dev/hda"

also some where in between it gave the error that harddisk's sector size is 2048 . it should be 512.
and hence nothing was saved in the partion table..


Whats the problem?

How to change the sector size?
 
Last edited:

axxo

99.9% Idle
i suppose this has caused due to partition overlap..try deleting and then recreating the partitions..
 
Status
Not open for further replies.
Top Bottom