FTP Clients and SQUID PROXY issues

Discussion in 'QnA (read only)' started by icecoolz, Dec 23, 2004.

Thread Status:
Not open for further replies.
  1. icecoolz

    icecoolz Active Member

    Joined:
    Jul 30, 2004
    Messages:
    1,221
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Bangalore
    Whenever I try to access an FTP site using an FTP client such as FLASHFXP or Smart FTP or any other client, it doesnt let me access. We are using SQUID proxy server version 2.4 stable. If I access the ftp site via the browser (both IE and FIREFOX) it works fine. I can access it. I can even acess it from FlashGet at times. But if I try to access it via an FTP client it doesnt work.

    Also I have given the sepcific proxy connection parameters in FlashFXP. I have tried all the different connection methods (except for socks as socks is not implemented by SQUID).

    I really dont get this one. Any help guys ?
     
  2. GameAddict

    GameAddict New Member

    Joined:
    Apr 28, 2004
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Hyderabad
    My guess...

    Hi,

    I think if you can alter the User Agent parameter of the FTP clients, they may work.AS FTP access is not denied (you said that IE can access it), so they are blocking the requests through User Agent field.My guess...try and let us know.


    About SOCKS on Squid, I have some doubt, because I have configured mIRC to use SOCKS5? :?:

    Bye!

    GA
     
  3. OP
    OP
    icecoolz

    icecoolz Active Member

    Joined:
    Jul 30, 2004
    Messages:
    1,221
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Bangalore
    no that didnt work...there is no user agent field in the FTP clients either in Smart FTP nor in FlashFXP. I am still looking around.....
     
  4. Ricky

    Ricky Active Member

    Joined:
    Feb 1, 2004
    Messages:
    1,158
    Likes Received:
    3
    Trophy Points:
    38
    check your ftp client, you have to make them to use Passive mode
     
Thread Status:
Not open for further replies.

Share This Page