• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

firefox 3- Use any oldest extension or theme!

Status
Not open for further replies.

Amir.php

Flying Visitor
It may be Possible some one already know it, But My Method is More easy and straightforward

Many of us now currently using the firefox 3.
No doubt the firefox is now a No. 1 browser. One of the most important thing which makes
firefox browser great is its extensions.
Extensions and themes are so important for increasing the capability of firefox.
Many of us already have stored a large collection of firefox previous versions extensions and themes.
But the problem is here is that as the new version of the firefox comes up, the previous versions extensions
does not working with new versions(compatibility issue).
Downloading and installing again and again these extensions and themes for new version is so boring
and time taking.
Also this makes our old saved extensions and themes un-usable.
Because it may be possible Mozilla go to releasing firefox 3.1 or 4 in future.
This means again these extension will going to unusable?
So to overcome with these types of the problems i am giving here a simple method- Use old firefox extensions
and themes with any newest version.


Need:
winrar only.
How to do it:

1. Right click on any of your previous saved extension> choose open with and Browse to winrar.
Now open this extension with winrar.
2. Here you can see a file called "install.rdf"
3. Drag and drop this file outside from winrar where your extension exist or any other place whrere you want(Not close winrar).
4. Right click on this "install.rdf" and open with NotePad.
5. Here is the main key which makes any extension compatible or not.
Simply search for these line:
<em:maxVersion>2.0.0.*</em:maxVersion>
This line makes firefox extension supported to Maximum version.
On some extensions it may be:
<em:maxVersion>3.a.0.</em:maxVersion>
or
<em:maxVersion>2.b.0.</em:maxVersion> etc.
No matter What is write here. Just change the Value from 2.0.0* to 4.0.0* and save this file and close.
6. Now simply Drag and drop this file return into winrar in which we have opend the extension.

7. "Archive name and parameter" dialog box will open. click ok.
8. close the winrar now.
****Done****
Now you can use this extension with firefox 3.
In the future just increasing Value from 4.0.0* to 5.0.0* keeps your extension always alive.
You can Do this same with Themes also.

Source: I have Take only idea from here. My overall steps are differ.
http://www.thesunsfinancialdiary.com/tech/using-old-extensions-in-firefox-3/
 

Vishal Gupta

Microsoft MVP
I prefer using "Nightly Tester Tools" extension instead of editing the extension file.

Download Nightly Tester Tools

Another method is using "about:config".

1. Type about:config in Firefox addressbar and press Enter. It’ll confirm, click on I’ll be careful, I promise! button.

2. Now right-click and select “New -> Boolean“. Give it name extensions.checkCompatibility and set its value to false.

3. Again right-click and select “New -> Boolean“. Give it name extensions.checkUpdateSecurity and set its value to false.

4. That’s it. You have done. Restart your browser and now all disabled extensions will be enabled and you’ll be able to install new incompatible extensions as well.

More Detailed Information
 
OP
Amir.php

Amir.php

Flying Visitor
^^Thank you very much to share new method.
But i shall prefer my method for making my old extension alive permantly.
why?
1. Because it may be more dangerous to turn off the extension compatibility checking of the firefox.
2. rather than editing browsers internal setting it will be best to edit extension if this extension we already have. Or if there are no compatible version of this extension recently available and it is very necessary for us.
3. my method makes our old extension parmanently compatible for future use.
4. we can use it on any others system after giving life into it.
5. suppose any of our newbee friend wants these extension then we can easily providing them.
But follow your method, if suppose we format the system, new installation of ff, or upgrade ff then we need again and again your method.
this is more frustrating than downloding a compatible extension or My method.
also just changing value from 2.0.0 to 4.0.0 is more easy than your method.

And thanks to all friends to like this tutorial.
continue giving your response.
 
Last edited:

Ecko

Wandering In Tecno Land
^^I prefer doing this using Mr Tech Toolkit

Just Click Addons
Then Select Tools
Then "Make All Compatible"
And you're Done
Whistle.gif

Also It provides many other features
Happy.gif
 
OP
Amir.php

Amir.php

Flying Visitor
^^Hey you are again trying to Edit firefox setting with this tool.
I also tested both Nighty and Mr. Tech but but i shall not prefer both because(again):
1. Because it may be more dangerous to turn off the extension compatibility checking of the firefox.
2. rather than editing browsers internal setting it will be best to edit extension if this extension we already have. Or if there are no compatible version of this extension recently available and it is very necessary for us.
3. my method makes our old extension parmanently compatible for future use.
4. we can use it on any others system after giving life into it.
5. suppose any of our newbee friend wants these extension then we can easily providing them.
But follow your method, if suppose we format the system, new installation of ff, or upgrade ff then we need again and again your method.
this is more frustrating than downloding a compatible extension or My method.
also just changing value from 2.0.0 to 4.0.0 is more easy than your method.

Dont think i am forcing any one to use my method.
But if you think with a cool mind then it is more safe than setting ff extension compatibility checking 0.
And MR Tech Toolkit can disable all add-on compatibility checks.
So why i prefer the safe and permanent method to make my extension compatible for newest version of ff if i already have stored this extension
 

Ecko

Wandering In Tecno Land
^^Hey you are again trying to Edit firefox setting with this tool.
I also tested both Nighty and Mr. Tech but but i shall not prefer both because(again):
Dont think i am forcing any one to use my method.
But if you think with a cool mind then it is more safe than setting ff extension compatibility checking 0.
And MR Tech Toolkit can disable all add-on compatibility checks.
So why i prefer the safe and permanent method to make my extension compatible for newest version of ff if i already have stored this extension

Since you're doing just the same as I did to change its version info (not source code) to make it compatible its makes the same effect as I did
Your method is correct "I strongly Agree" but mine is less cumbersome & easier for Noobs :D
BTW Dude its very easy to restart firefox in Safe Mode so I don't think if there's some problem then we can't handle it
 

NIGHTMARE

ANGEL OF DEATH
I prefer using "Nightly Tester Tools" extension instead of editing the extension file.

Download Nightly Tester Tools

Another method is using "about:config".

1. Type about:config in Firefox addressbar and press Enter. It’ll confirm, click on I’ll be careful, I promise! button.

2. Now right-click and select “New -> Boolean“. Give it name extensions.checkCompatibility and set its value to false.

3. Again right-click and select “New -> Boolean“. Give it name extensions.checkUpdateSecurity and set its value to false.

4. That’s it. You have done. Restart your browser and now all disabled extensions will be enabled and you’ll be able to install new incompatible extensions as well.

More Detailed Information

its mean my all add-ons r worked i think no bcoz i tried but not working
 
OP
Amir.php

Amir.php

Flying Visitor
Since you're doing just the same as I did to change its version info (not source code) to make it compatible its makes the same effect as I did
Your method is correct "I strongly Agree" but mine is less cumbersome & easier for Noobs :D
BTW Dude its very easy to restart firefox in Safe Mode so I don't think if there's some problem then we can't handle it

No i am not doing the same.
Actually my aim is to Make My all stored extension and theme permanently compatible and editing once you not need to depend on other extension or patch in future.
Also Many times some situations occurred when starting firefox in safe mode will not work and only one way remains to uninstall it.
But it not remove ff fully and previous registry setting may remains. so a long process will be follow to remove ff successfully and install it again.
But I am very happy that there are three different Methods are available and we know them.
Also thank you very much to you also to tell me about this method.:razz:
 

Ecko

Wandering In Tecno Land
No i am not doing the same.
Actually my aim is to Make My all stored extension and theme permanently compatible and editing once you not need to depend on other extension or patch in future.
Also Many times some situations occurred when starting firefox in safe mode will not work and only one way remains to uninstall it.
But it not remove ff fully and previous registry setting may remains. so a long process will be follow to remove ff successfully and install it again.
But I am very happy that there are three different Methods are available and we know them.
Also thank you very much to you also to tell me about this method.:razz:
I'll be eager to know what changes you do other than changing the version info to make extensions compatible (PM Me)
Your effect isn't easier to implement & can't be reverted back easily too
BTW I'm Settled with 3 ways :D
Njoy..........!!!
 
Status
Not open for further replies.
Top Bottom