Fedora Core 5+Nokia 6070+CA 42+AirTel GPRS

Discussion in 'Open Source' started by titun, Oct 2, 2006.

Thread Status:
Not open for further replies.
  1. titun

    titun Guest

    I have written the title as "Fedora Core 5+Nokia 6070+CA 42+AirTel GPRS" so that searching for this particular problem might be easier. & if this problem is sorted out it can also help out many other newbees with same problem.

    I have Nokia 6070, a CA 42 USB-Serial Data Cable, AirTel GPRS connection, which works fine on Windows XP. After searching a lot how to connect the phone and use GPRS via the cable I came across this UBUNTU forum guide. I did not knew about WvDial before. I did just as mentioned there and configured my wvdial.conf which now looks like :-
    _______________________________________________
    [Modem0]
    Modem = /dev/ttyS1
    Baud = 19200
    SetVolume = 0
    Dial Command = ATDP
    Init1 = ATZ
    Init3 = ATM0
    FlowControl = XONXOFF

    [Dialer Defaults]
    Modem = /dev/ttyUSB0
    Baud = 230400
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem
    Phone = *99#
    Username = *
    Password = *
    Stupid Mode = 1
    ________________________________________________
    I have no internal(soft) or external modem except the N 6070 as it recognises. All set, I WVDIALed and got o/p as below :-
    ____________________________________________
    [root@airtelgprs ~]# wvdial
    --> WvDial: Internet dialer version 1.54.0
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT*99#
    --> Waiting for carrier.
    ATDT*99#
    CONNECT
    ~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Mon Oct 2 10:38:04 2006
    --> pid of pppd: 2504
    --> Using interface ppp0
    --> pppd: ults
    --> pppd: ults
    --> pppd: ults
    --> local IP address 172.28.37.241
    --> pppd: ults
    --> remote IP address 10.6.6.6
    --> pppd: ults
    --> primary DNS address 202.56.230.5
    --> pppd: ults
    --> secondary DNS address 202.56.230.6
    --> pppd: ults
    _______________________________________
    Now it shows that GPRS is activated, which is also shown in the phone, the thw icons, open lock and small G within square as u ppl know when we use packet data connection. Now I should be able to browse net, but not a single page opens.

    What is the step I am missing ? Just see the last portion of the o/p in the post link I have given :-
    ___________________________________________
    Carrier detected. Starting PPP immediately.
    --> Starting pppd at Wed Apr 26 23:11:44 2006
    --> pid of pppd: 11096
    --> Using interface ppp0
    --> local IP address 10.33.228.142
    --> remote IP address 10.6.6.6
    --> primary DNS address 193.35.133.10
    --> secondary DNS address 193.35.134.10
    ____________________________________________
    In my o/p I have this "pppd: ults" string after each line which he does not. Is only due to I use FC5 and he uses Ubuntu. Or do I need to configure pppd also. I read man pages of wvdial, pppd but could not find out where am I wrong. Also PINGed remote IP, which showed :-
    ________________________________________
    [root@airtelgprs ~]# ping -c1 10.6.6.6
    PING 10.6.6.6 (10.6.6.6) 56(84) bytes of data.
    From 203.101.95.209 icmp_seq=1 Time to live exceeded

    --- 10.6.6.6 ping statistics ---
    1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

    [root@airtelgprs ~]#
    _________________________________________________
    --> What is "Time to live exceeded" ?
    Any suggestion is welcome.
     
  2. Tech Geek

    Tech Geek Wise Old Owl

    Joined:
    Sep 21, 2006
    Messages:
    1,602
    Likes Received:
    18
    Trophy Points:
    0
    Location:
    Cyber Hell
    THANKS!!! a lot dude. :D
     
  3. OP
    OP
    titun

    titun Guest

    Thanks !! But for what ?? :confused: Do u also have a same kinda problem ?
     
  4. subratabera

    subratabera Just another linux lover.

    Joined:
    Jun 6, 2006
    Messages:
    564
    Likes Received:
    26
    Trophy Points:
    0
    Location:
    Bangalore, KA
    Hi titun,
    I think the "named" service is not running. You have to start the "named" service.
    Follow these steps...this might solve your problem...

    1)open a terminal.
    2)su - (su with a dash)
    3)enter password...
    4)service named start (tried on Fedora Core 5)

    After starting the "named" service, try to reconnect and open a website.

    Subrata Bera.
     
    1 person likes this.
  5. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Sorry but why is named required? Isn't DNS given by airtel. Actually I don't have much idea of dynamic IP and DNS so I want to confirm.
     
    1 person likes this.
  6. OP
    OP
    titun

    titun Guest

    @subratabera, I did just what u said, su with a dash, & then wvdial, but the same thing, net gets connected, but can't open any page.

    Tried to use KPPP shown in the start button>internet menu, but don't know which setting is what, like PAP, what are they.
    Oh !! So many things to :confused: remember, understand for a simple net connection.

    Trying for past 3/4 days to access net. So what good is linux ?
     
  7. gary4gar

    gary4gar GaurishSharma.com

    Joined:
    May 21, 2005
    Messages:
    4,094
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    Jaipur
    ^^^
    hey don't give so early its dont default of linux something is missing on ur part.
    try try until you succeed
     
    1 person likes this.
  8. eddie

    eddie El mooooo

    Joined:
    Jan 26, 2006
    Messages:
    1,414
    Likes Received:
    14
    Trophy Points:
    0
    Location:
    India
    Connect to GPRS once again. This time open a terminal window, change to super-user and give us output of following two commands.
    Code:
    cat /etc/resolv.conf
    route
     
    1 person likes this.
  9. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    may be the ppp interface may not be the default connxn.try
    Code:
     route add default ppp0
     
    1 person likes this.
  10. alanpaladka

    alanpaladka Member

    Joined:
    Sep 19, 2004
    Messages:
    185
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mangalore, Karnataka
    Open file:/etc/resolv.conf and enter following setting

    Code:
    service named start
    nameserver 202.56.250.5
    nameserver 202.56.250.6
    I'm also using Airtel GPRS in FC4 via N70. It's great....
     
    1 person likes this.
  11. OP
    OP
    titun

    titun Guest

    Successfully connected Fedora Core 5+Nokia 6070+CA 42+AirTel GPRS

    I created this thread almost 4 months ago. Not being able to find the solution left the thread.

    Today it is solved.
    Let me repeat, I used Fedora Core 5 + Nokia 6070 + CA 42 Data Cable + AirTel GPRS.

    What I did :

    Fresh installed FC5 again last night.
    su :
    password :
    [ Checked my mobile phone's Vendor ID & Product ID earlier in the other OS ;) ]
    : /sbin/modprobe usbserial vendor=0x0409 product=0x04B0

    then

    : wvdialconf create [ This command did not show me any result ]
    Manually typed following things in /etc/wvdial.conf

    [Dialer Defaults]
    Modem = /dev/ttyUSB0
    Baud = 230400
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem
    Phone = *99#
    Username = A
    Password = B
    Stupid Mode = 1

    in another console,

    : su -
    : password :

    : service named start

    and it it displayed named service started.
    Then
    : wvdial
    The O/P came as follows
    _________________________________
    --> WvDial: Internet dialer version 1.54.0
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT*99#
    --> Waiting for carrier.
    ATDT*99#
    CONNECT
    ~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Fri Feb 16 09:51:27 2007
    --> pid of pppd: 3495
    --> Using interface ppp0
    --> pppd: alog Modem
    --> pppd: alog Modem
    --> pppd: alog Modem
    --> local IP address 172.28.41.189
    --> pppd: alog Modem
    --> remote IP address 10.6.6.6
    --> pppd: alog Modem
    --> primary DNS address 202.56.230.6
    --> pppd: alog Modem
    --> secondary DNS address 202.56.230.5
    --> pppd: alog Modem
    ___________________________________
    It means net is now connected.
    I was able to open google.com . But it took a longer time than normal, so closed connection. Opened /etc/resolv.conf and entered the following :

    service named start
    nameserver 202.56.250.5
    nameserver 202.56.250.6

    Now I just do this
    : su
    : password
    : wvdial

    3 simple steps to enjoy AirTel GPRS in Linux. Will soon upgrade to latest versions of Tux.
    Heartly thanks and reputation points to everyone who replied in this thread.
    I used the follwing links as my reference along with the help of you guys.
    1] Using a GSM Cellphone as a GPRS Modem - Ubuntu Forums

    2] Connecting Fedora Core to Airtel GPRS using Nokia 6020 and CA-42 cable
     
Thread Status:
Not open for further replies.

Share This Page