easy Howto AIGLX + Compiz on Ubuntu Edgy/Debian Etch/Sid and GNOME

Discussion in 'Open Source' started by praka123, Dec 3, 2006.

Thread Status:
Not open for further replies.
  1. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    I configured AIGLX with intel 915GV onboard GFX using the following howto found on
    http://wizah.blogspot.com/2006/10/debian-how-to-aiglx-compiz.html
    known working:
    ATI: Radeon 7000 through X850 (r100 through r400 generations)
    Intel: i830 through i945
    nVidia: all cards supported by the driver 1.0-9625 or higher

    And for Ubuntu Edgy details below link will be useful.
    http://gandalfn.wordpress.com/howto/howto-compiz-aiglx-on-edgy/

    I know about Beryl stuff exists.any easy Beryl configuratiom HW2 and beryl repos for debian and ubuntu for intel 915 boards.pls discuss here.
     
    Last edited: Dec 3, 2006
  2. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
  3. sariq

    sariq Guest

    oops now i see why people prefer nano over gedit :)

    will it work on my laptop with celeron 1.5GHz / Intel 915
     
  4. OP
    OP
    praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    It will work.hope u have RAM 256@minimum
     
  5. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    My Laptop has 1.6 GHz/Intel 915/512 MB RAM. It works awesome.

    Here are my screen shots.
     
  6. sariq

    sariq Guest

    its working now aiglx+beryl. compiz have some problems - windows borders were missing.

    how to screen shots of cube effect - print screen doesnt work while pressing other keys
     
  7. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    ^^U must have mixed/started beryl and compiz together. I faced problem too when I tried to install compiz after beryl. But soon realised the problem and uninstalled compiz.

    Neways to take the screenshot use ksnapshot, give the timing delay in it like 4 seconds or 10 seconds wateva and then rotate the cube. It will take the snapshot after the given delay. Simple!! :cool:
     
  8. OP
    OP
    praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    easy Howto AIGLX + Beryl on Ubuntu Edgy and GNOME

    Beryl+AIGLX

    OK.experiments time!assuming u have DRI(direct rendering support!)
    Code:
    glxinfo | grep direct
    if above got dri=yes.
    I have tried the Beryl+AIGLX on my Ubuntu Edgy.here is my brief howto for intel 915G board on-board GFX card users:
    First i added the beryl-svn repo to the end of my /etc/apt/sources.list

    Code:
    ~$sudo gedit /etc/apt/sources.list
    deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
    then installed beryl metapackage.
    Code:
    ~$sudo apt-get update
    ~$sudo apt-get install beryl emerald emerald-themes emerald-themes-extra
    
    then issue ALT+F2 to get run dialog;inside the dialog box-run:
    Code:
    gksudo gedit /etc/X11/xorg.conf
    
    find the section "module" and make sure u have "dbe" also.
    Code:
    Section "Module"
            Load    "i2c"
            Load    "bitmap"
            Load    "ddc"
            Load    "dri"
            Load    "extmod"
            Load    "freetype"
            Load    "glx"
            Load    "int10"
            Load    "type1"
            Load    "dbe"
            Load    "vbe"
    EndSection
    in the section "Device",add
    Code:
    Option "XAANoOffscreenPixmaps" "true"
      
    Code:
    Section "Device"
            Identifier      "Intel Corporation 82915G/GV/910GL Express Chipset Famil
    y Graphics Controller"
            Driver          "i810"
            BusID           "PCI:0:2:0"
            Option "XAANoOffscreenPixmaps" "true"
    EndSection
    And add following lines after skipping a line:
    Code:
    Section "Extensions"
            Option "Composite" "true"
    EndSection
    Save the file.now we can start Beryl by issuing:
    Code:
    ~$beryl-manager &
    For starting beryl automatically on every boot on Gnome,we need to add the following to the menu>System>Preferences>Sessions.select the Startup Programs TAB,now using add button add below command:
    Code:
    beryl-manager
    Enjoy effects.
    default commands are avail at below beryl wiki:
    http://wiki.beryl-project.org/index.php?title=Tips/Default_Commands
    below howto is very helpful:
    http://wiki.beryl-project.org/index.php?title=Install/Ubuntu/Edgy/AiGLX
    You can take a snapshot using print button in kbd.and for recording a session with beryl effects u can use istanbul recorder
    or gtk-recordMyDesktop
     
    Last edited: Jan 6, 2007
    baccilus likes this.
  9. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    Last edited: Dec 4, 2006
  10. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    @Prakash : A little correction!

    U have to make sure to add public key for the repository

    wget http://ubuntu.beryl-project.org/quinn.key.asc -O - | sudo apt-key add -
    or
    wget http://ubuntu.beryl-project.org/quinn.key.asc --quiet -O - | sudo apt-key add -



    Next its not a good practise to add beryl to the default gnome session! U should make a separate session for gnome+beryl (besides gnome) and name it as beryl!

    for gnome, we have the script
    For kde
    For xfce
    Next
    One of the above scripts is to be used and saved as "startberyl.sh" in /usr/bin. Since we are dealing with gnome here, we save the gnome's script.

    Next, we give the rights and command as => sudo chmod a+x /usr/bin/startberyl.sh

    Next we add the separate session, and make a new file => /usr/share/xsessions/Beryl.desktop and add the following code to it!

    :)

    @mehul : Do u have compiz installed already?
     
  11. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    I removed compiz from Ubuntu and I haven't even installed it on Mandriva so far.
     
  12. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
  13. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    It's the same.
     
  14. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    Something must be wrong, coz I got a white screen when I intalled compiz after beryl. U may undo everything and re-try from the start!
     
  15. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    I am positively sure that compiz isn't installed on Mandriva. I rechecked it too. I will look back if reinstalling beryl helps.
     
  16. OP
    OP
    praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    @techfuture:try removing ur ~/.beryl/, ~/.beryl-managerrc (or edit this file to ur needs if u know it ofcourse ;) ).
    Another problem is AIGLX is not available with Xorg versions before 7.1.
    u can check if AIGLX available on ur X server by:
    Code:
     ~$cat /var/log/Xorg.0.log | grep AIGLX 
    if enabled,will show (==) AIGLX enabled.
    In my Debian testing apt pinned with sid+experimental and ubuntu edgy beryl+aiglx works great.and i have heard that for some GFX cards like nvidia etc XGL X-server works fine.


    but as u know AILGX is not another X server,it is integrated into X.org 7.1+ releases.
    @mediator:that is helpful noob's.i thought like installing gpg keys for servers are known by most as ppl tends to fiddle with their /etc/apt/sources.list to add or remove apt-repos.u can add gpg keys as
    Code:
    gpg --keyserver subkeys.pgp.net --recv KEY
    gpg --export --armor KEY | sudo apt-key add -
    __________
    And i meant the HW2 for intel onboard GFX cards as i got only that!:(
     
    Last edited: Dec 5, 2006
  17. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    Hmmm, neways mine is also Intel onboard graphics.
     
  18. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    @prakash AIGLX is enabled but it says DRI module not loaded. I guess I need to look more onto this. BTW, I have onbaord graphics and it's detected as savage.
     
  19. OP
    OP
    praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    Ahaa...u need DRI support for all of these effects!
    does a modprobe savage and modprobe savagefb and restart X session helps!
    "savage" dont know about that card,do a bit of googling...or u can recompile linux kernel newest with those dri modules latest available as u probably knows..
     
  20. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    DRI was enabled earlier but after making these changes to Xorg, DRI is disabled.
     
Thread Status:
Not open for further replies.

Share This Page