• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

DVD RW not recognised in BIOS

Dev_t

Broken In
Hi everyone, this is my first post on ThinkDigit. I hope I am at the right place.

The problem I am facing is regarding my Sony DVD RW. I own a Compaq machine with the following config at present:
OS: Windows XP Professional SP2
CPU: Intel Pentium 4 524 3.06 GHz
RAM: Total 1280 MB (2 sticks; 1024 MB, 256 MB )
Motherboard: Gigabyte GA-8S661FXM-775
BIOS: Award S/w international, v F7a
HDD: Western Digital Caviar 250 GB
OD: Sony DVD RW AD-7240
Audio: Realtek AC'97

It came with an IDE HD and an IDE CD RW. After some time I installed the SATA DVD RW in one of the two SATA ports. Everything was working fine and I could boot from my DVD RW. Recently my IDE HD went kaput. I replaced it with a SATA HD (WD Caviar). I had to reinstall the OS in the new HD. At that time also I could boot from my DVD RW. But last week when I tried to install Linux by booting from a live DVD, I couldn't. The BIOS is not showing the DVD RW although its working fine in Windows after booting. I have removed my IDE HD and CD RW. Please help me out.:confused:
 

pramudit

Gaming hardcore
It is possible that it might be given some different name in bios...
 
Last edited:

Alok

Adventurer
If it is working in windows then it must be in bios. Insert your linux dvd then restart your pc and while boot press F8 for boot drive selection.
 
Last edited:

coderunknown

Retired Forum Mod
it'll definitely show in bios. else how will windows recognize it? clear cmos & load default settings. check if anything comes.
 

Sujeet

Undead!!!
Your SATA DVD Drive is of which brand??? you should look for brand and drive specific name in BIOS boot menu..for e.g a sony drive will appear something like this in boot menu SONY DVD RW AW-G170A.
 

topgear

Super Moderator
Staff member
@ OP - just set DVD/CD drive as the primary / 1st boot option in bios setting - this will fix your issue for sure and you'll be able to boot from bootable cd/dvds ;-)
 
OP
D

Dev_t

Broken In
Thanks guys for suggesting the solutions but the problem is persistent.
I have tried all the solutions:?:

1. Reset the BIOS to default optimal settings

2. Clear CMOS by removing the battery

3. Changing the boot preference. My sequence was:
CD ROM
HDD
USB-HDD

4. Interchanging the cables: since my HDD was working fine so I thought the cable on my DVD RW might have gone wrong. So I switched the cables but it still recognized only one device.

5. Interchanging the ports: I interchanged the ports of the two devices. Now the DVD RW was on the port on which earlier the HDD was working. When I rebooted my PC this time it recognised my DVD RW as SONY DVD RW but it din't recognize the HDD. It won't boot from HDD now and shows DISK FAILURE error.

Another thing. When I tried the no. 5 step I also tried booting using UBUNTU LIVE DVD. It booted from the DVD RW but when I chose the Install Ubuntu option it just got stuck on the first screen with progress bar and won't give any error like "no hard disk" found or something like that..

strange problem:banghead::hyper:
 

topgear

Super Moderator
Staff member
^^ congrats ! you have just pin pointed the problem - it's the mobos sata port that gone bad - that's why no device plugged in that port is not working.

Buy a external sata DVD drive enclosure and use the DVD drive as a USB dvd drive ;-)
 
OP
D

Dev_t

Broken In
I think you are right topgear...can this be fixed without having to invest in a sata dvd drive enclosure..like replacing the port or something like that
 
Top Bottom