difference in internet speed in diff system

guhanath

Journeyman
Hi All,

I use hathway wifi connection(50mbps connection) in my home. I see a peculiar problem with respect to internet speed.
I have a desktop(win 10, updated to creators update), connected via wifi usb adapter(lexosys nano usb). I use flashget downloader/regular downloads in my browser.The desktop is near to router.

I have a laptop (vista) connected to the same router. The laptop is farther from router.

I noticed that my internet speed/download is very good(approx 3 mbps) when i use it from my laptop. However the net speed from my desktop is struggling around 250 kbps. I tried clearing cache/settings/ wifi reboot etc but the problem remains. I am noticing this issue only in the past 2 weeks (after creators update).

Can anyone suggest solutions/ techniques to resolve this issue? Should I try connect to LAN cable and verify/ clearn DNS cache etc?

Thanks
Guhan
 

patkim

Cyborg Agent
Things to try
-As already suggested first check what speed you get on LAN cable. If it's good may be it's time to check on WiFi
-Try booting to a Live Linux distro say Linux Mint and check if it detects your WiFi adapter on Desktop, if yes and speed is good then it's most liklely Windows issue
-Try re-installing drivers for your WiFi adapter on Windows
-Do a system restore and check if any previous state was better.
-On your router try toggling WMM option (If exists) Try it with that option Enabled and other times Disabled and check if there's any difference
-I had a similar issue with my Sony Vaio laptop. The speed on WiFi was poor only on that laptop. Rest of the devices were good. I took a drastic step and invested my time in full and clean re-install of Windows 7 and WiFi drivers on my Vaio laptop and the problem was solved.
 
Last edited:

Hrishi

******************
You may have accidentally enabled QoS on the PC.

Sent from my ONE E1003 using Tapatalk
 

topgear

Super Moderator
Staff member

Open Group Policy Editor by pressing win+r ( keys ) and opening the run box. type the following :

gpedit.msc

Hit Enter ( key )

Go To = Local Computer Policy > Administrative Templates > Network > QOS Packet Scheduler , then on the right window, right click on the Limit reservable bandwidth setting and select the Edit:

On the setting tab, select the enabled radio button, and Where it says “Bandwidth limit %“, change it to 0 or as per your liking.

Now, go to Control Panel > Network and Internet > Network and Sharing Center and Click on Change adpater settings

Right-click on your desired connection interface connection and select Properties :

Make sure QOS Packet Scheduler is selected.
 
Top Bottom