Dial up modem not working on Fedora 5(64-bit)

Discussion in 'Open Source' started by phreak0ut, Jul 14, 2006.

Thread Status:
Not open for further replies.
  1. phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    Hi!
    I´m using Fedora Core 5(64-bit) with kernel version 2.6.15-1.2054 on my system with the following configuration.
    AMD Athlon 64 3200+ (Venice Core)
    MSI RS-480M2 motherboard
    512 MB DDR RAM
    160GB SATA Seagate harddrive

    I tried to install the Linux driver for the modem DFM-560IS+++ on this configuration. The modem works absolutely fine with Windows 98/XP. Below is the log of the problem facing by me. Hope you can help me out.

    _____________________________________________________________________________
    _____________________________________________________________________________

    (1) Installing through the *.rpm available on the CD didn´t work fine, so used the *.tar.gz package to install. Below is the installation instruction notes given on the CD and followed exactly by me.


    If you have obtained the driver package in tar format:

    1. extract the package with "tar -xzf hsflinmodem-<version>.tar.gz"

    2. change to the package directory with "cd hsflinmodem-<version>"

    3. run "make install" from the top of the package directory.

    4. run "hsfconfig" to complete the installation and configure your modem.

    (Alternatively to this whole procedure you may generate RPMS from the tar
    package using rpm -ta hsflinmodem-<version>.tar.gz")


    --------------------------------------------------------------------------
    (2)Below is the installation which followed after typing the command:


    [root@localhost hsflinmodem-4.06.06.02]# make install
    make[1]: Entering directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/inf'
    install -m 644 linux_athens.inf linux_hsfi.inf linux_hsf.inf linux_intel_smartmc.inf linux_smarthsf.inf /etc/hsf/inf
    make[1]: Leaving directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/inf'
    make[1]: Entering directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/inf2bin'
    cc -I../imported/include -I../modules/osspec/include -DFRAME_WORK=FWK_LINUX_SOFTK56 -DFRAME_WORK_IMPORTED -DOVERRIDE_NEW=1 -DPORTABILITY=0 -DMULTYDP -DHSFLINUXVERSION="\"4.06.06.02\"" -O2 -Wall -c -o inf2bin.o inf2bin.c
    inf2bin.c: In function ‘ProcessString’:
    inf2bin.c:230: warning: pointer targets in assignment differ in signedness
    inf2bin.c: In function ‘ProcessCtryStruct’:
    inf2bin.c:387: warning: pointer targets in assignment differ in signedness
    cc -o hsfinf2bin inf2bin.o
    install -m 755 hsfinf2bin /usr/sbin/hsfinf2bin
    make[1]: Leaving directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/inf2bin'
    make[1]: Entering directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/firm2bin'
    cc -I../imported/include -I../modules/osspec/include -DFRAME_WORK=FWK_LINUX_SOFTK56 -DFRAME_WORK_IMPORTED -DOVERRIDE_NEW=1 -DPORTABILITY=0 -DMULTYDP -O2 -Wall -c -o firm2bin.o firm2bin.c
    cc -o hsffirm2bin firm2bin.o
    install -m 755 hsffirm2bin /usr/sbin/hsffirm2bin
    install -m 644 cnxykf.hex /etc/hsf
    make[1]: Leaving directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/firm2bin'
    make[1]: Entering directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/scripts'
    sed \
    -e 's!@PREFIX@!/usr!g' \
    -e 's!@HSFETCDIR@!/etc/hsf!g' \
    -e 's!@HSFLIBDIR@!/usr/lib/hsf!g' \
    -e 's!@HSFINFDIR@!/etc/hsf/inf!g' \
    -e 's!@HSFSERIALMINOR@!64!g' \
    -e 's!@HSFBININF_FILE@!/etc/hsf/nvram.bin!g' \
    -e 's!@HSFFIRMWR_FILE@!/etc/hsf/firmware.bin!g' \
    -e 's!@HSFLINUXVERSION@!4.06.06.02!g' \
    < hsfconfig.in > hsfconfig
    chmod 755 hsfconfig
    install -m 755 hsfconfig hsfstop /usr/sbin
    install -m 755 hsfsysid /usr/bin
    make[1]: Leaving directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/scripts'
    cc1: error: /usr/src/linux/include/linux/config.h: No such file or directory
    cc1: error: /usr/src/linux/include/linux/version.h: No such file or directory
    cc1: error: /usr/src/linux/include/linux/version.h: No such file or directory
    make[1]: Entering directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/modules'
    rm -rf "/usr/lib/hsf/config.mak" "/usr/lib/hsf/imported" "/usr/lib/hsf/modules"
    mkdir -m 755 -p /usr/lib/hsf/modules
    (cd .. && find config.mak imported -depth -print | cpio -pdm /usr/lib/hsf)
    3664 blocks
    find . \( -name '*.[ch]' -o -name '*.mak' -o -name '[Mm]akefile' \) -print | cpio -pdm /usr/lib/hsf/modules
    558 blocks
    find binaries -depth -print | cpio -pdm /usr/lib/hsf/modules
    0 blocks
    make[1]: Leaving directory `/root/Desktop/Applications,patches/Dialupmodemdriver/hsflinmodem-4.06.06.02/modules'
    install -m 444 LICENSE /usr/lib/hsf

    --------------------------------------------------------------------------
    (3) After the installation, we require to type ¨hsfconfig¨ command to configure the modem. But, I get the error message which I post below.

    [root@localhost hsflinmodem-4.06.06.02]# hsfconfig
    Linux HSF softmodem drivers, version 4.06.06.02
    grep: /proc/ksyms: No such file or directory
    /usr/bin/hsfsysid: line 99: [: too many arguments
    HSF drivers currently don't support SMP (Symmetric Multi-Processing) kernels.

    First, ensure that the proper kernel source and compiler packages
    from your distribution vendor and/or the community are installed.

    The Linux kernel can then be reconfigured by running "make menuconfig"
    under the kernel source directory (usually /usr/src/linux).

    Verify that the proper options for your system are selected,
    and that CONFIG_SMP ("Symmetric multi-processing support" under
    "Processor type and features") is disabled, as this driver is
    presently designed to work on single-processor machines.

    Then compile and install your new kernel (for more information aboutthis procedure, see the README file under the kernel source directory),
    reboot the system using the new kernel, and re-run "hsfconfig".
    [root@localhost hsflinmodem-4.06.06.02]#

    --------------------------------------------------------------------------

    Please tell me if I´m going wrong somewhere, else if there is anything wrong with the package or the OS.
     
    Last edited: Jul 14, 2006
  2. OP
    OP
    phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    Could anyone PLEASE tell me what is wrong and what needs to be done??? I've started this topic nearly 3 months back and not a single reply :( :(
     
  3. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    I dunno if there's a difference in dialup connection between 32 and 64 bit distros, but I used to run dialup on fedora 3.

    System>network>"new" connection>modem(dialup) : fill the entries and in extra initialization string type "atx 1". Now try!
     
  4. eddie

    eddie El mooooo

    Joined:
    Jan 26, 2006
    Messages:
    1,414
    Likes Received:
    14
    Trophy Points:
    0
    Location:
    India
    The error is right there. Kernels with SMP support are not supported and Fedora kernel is SMP enabled. These drivers are provided by linuxant.com but your speed is limited to 14.4kbps. You have a few options now:

    1) Recompile your kernel, disable SMP support and install drivers from linuxant.com
    2) Buy an external modem and throw away that no-good internal modem.
     
  5. OP
    OP
    phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    I'm a linux noob and it will take sometime before I can get proficient with it. How can I disable SMP for this?

    Wish I could, but I cant.
     
  6. eddie

    eddie El mooooo

    Joined:
    Jan 26, 2006
    Messages:
    1,414
    Likes Received:
    14
    Trophy Points:
    0
    Location:
    India
    Without recompiling the kernel, I really doubt that you can disable SMP.

    If you can't do either of the things that I suggested, at least go to linuxant.com and try the latest drivers from there. Who knows, they might be supporting SMP kernels now.
     
  7. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    eddie, isn't it possible to install non-smp kernel from repos? It should be available. But, since I haven't used a 64 bit system, I am not aware of the pitfalls.
     
  8. eddie

    eddie El mooooo

    Joined:
    Jan 26, 2006
    Messages:
    1,414
    Likes Received:
    14
    Trophy Points:
    0
    Location:
    India
    No idea man...and I highly doubt that they would have a non-SMP kernel for 64bit but it is worth a try.
     
    phreak0ut likes this.
  9. OP
    OP
    phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    Well, thanks for suggestion. I've moved to SuSE 10.2 now. I'll surely be checking out the site you mentioned and keep you posted..
     
  10. OP
    OP
    phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    The driver suggested from Linuxant worked like a charm! Thanks a lot Eddie. Though I'm able to dial into the network, the connetion is very, very slow. Thanks again though! :)
     
  11. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    As eddie said, the speed is limited to 14.4kbps, so browsing's gotta be dead slow.
     
    Last edited: Jan 29, 2007
  12. OP
    OP
    phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    Hmmmm...... well in that case, I hope I'm able to run atleast AsteriskNOW for an IVR.
     
  13. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    I doubt if anything will work fine at this speed. Check if you can find some other drivers somewhere else. Maybe you will atleast get 56kbps or whatever is supported speed.
     
Thread Status:
Not open for further replies.

Share This Page