Can't Access the CDROM in KNOPPIX 3.4

Discussion in 'QnA (read only)' started by vrnoormd, Dec 4, 2004.

Thread Status:
Not open for further replies.
  1. vrnoormd

    vrnoormd New Member

    Joined:
    Nov 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Vellore
    I am recently installed knoppix 3.4 from Live Cd.

    It works fine, but cdrom is not mounting, it says cdrom is not access.

    I can enter in root also it refuses.

    Please Help me how to mount the cdrom?
     
  2. GNUrag

    GNUrag FooBar Guy

    Joined:
    Jun 22, 2004
    Messages:
    1,246
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Interwebs
    Please check where you are posting...

    Do this thing...

    1) After installing Knoppix on hard disk, Reboot your system with the Knoppix Live CD.
    2) Mount the ext3 partition where knoppix is installed on the hard disk
    3) Open Konsole and become root be giving $ su

    4) Go the the mnt directory of the ext3 partition
    5) Delete the two Symlinks called cdrom , floppy
    6) Edit the etc/fstab file on the hard disk. and make them point to /cdrom and /floppy instead of /mnt/cdrom and /mnt/floppy

    7) Take out the CD and Reboot
     
  3. OP
    OP
    vrnoormd

    vrnoormd New Member

    Joined:
    Nov 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Vellore
    Thankx GNUrag,

    I do all you have mentioned,
    but its not working
     
  4. GNUrag

    GNUrag FooBar Guy

    Joined:
    Jun 22, 2004
    Messages:
    1,246
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Interwebs
    post your /etc/fstab file.... I will give you a modified fstab file.... is that okay ?
     
  5. sharma_deepak83

    sharma_deepak83 New Member

    Joined:
    Nov 13, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Simple as it can be???

    Search for hardware browser in System Tools or settings ( I always mix up the 2). click on the cdrom and down u u can see the device name like

    /dev/hda or something depending upon where u have attached ur cdrom (primary master, slave blah blah)

    Now just open the fstab file in the /etc directory in gedit or any other editor u are comfortable... Look for somethin like
    /dev/hd** /mnt/cdrom blah blah

    now instead of this hd** place the device we got from the hardware browser.......

    If u are not able to login as root do the following .........


    Start ur comp and one boot screen in case of GRUB press e and enter

    " LInux 1 " or "1" in the line starting with "kernel Blah blah"

    in case of LILO press esc and enter "linux 1"

    U will get the shell of the root withpout being asked for the password

    not type "passwd" and then ur new password ... Now reboot and way u go..............
     
  6. OP
    OP
    vrnoormd

    vrnoormd New Member

    Joined:
    Nov 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Vellore
    Thanks GNUrag

    here i am sending the fstab file copyjavascript:emoticon(':lol:')

    -------------------------

    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/hda10 / ext3 defaults,errors=remount-ro 0 1

    proc /proc proc defaults 0 0
    /dev/fd0 /auto/mnt/auto/floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    usbdevfs /proc/bus/usb usbdevfs defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/hdc/mnt/auto/cdrom iso9660 defaults,ro,user,exec,noauto,umask=000 0 0
    /dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
    # Added by KNOPPIX
    /dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda5 /mnt/hda5 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda6 /mnt/hda6 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda7 /mnt/hda7 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda8 /mnt/hda8 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda9 /mnt/hda9 ext3 noauto,users,exec 0 0
    # Added by KNOPPIX
    /dev/hda11 none swap defaults 0 0
    :lol: :lol:
     
  7. h4ck3r

    h4ck3r Guest

    dont depend on others

    Excuse me mr.gnurag .. coz iam gonna tell onething to this man vr...

    Hey u can use "man fstab" in a terminal to know more.. U should not depend on anybody for help..I knew nothing abt linux at first..but i used the man commands and i discovered a lot.
     
  8. GNUrag

    GNUrag FooBar Guy

    Joined:
    Jun 22, 2004
    Messages:
    1,246
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Interwebs
    Re: dont depend on others

    In Knoppix 3.4, verify is you have /floppy and /cdrom directories present. (they are present. just check again.... and yes, in Knoppix floppies and cdrom are mounted in the root directories) .... knoppix team tried to write an automount script, but it still gives problems...

    How ever here is the modified fstab file. If possible, then delete the /mnt/auto, /mnt/cdrom* and /mnt/floppy directories. You wount be able to delete normally. Reboot from Knoppix Live CD, mount those partitions and then delete.

    And yes, always mount your floppies and CDROM by this method:
    $ mount /floppy
    $ mount /cdrom


    Code:
    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/hda10 / ext3 defaults,errors=remount-ro 0 1
    /dev/hda11 none swap defaults 0 0
    
    proc /proc proc defaults 0 0
    /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    usbdevfs /proc/bus/usb usbdevfs defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/hdc /cdrom iso9660 defaults,ro,user,exec,noauto,umask=000 0 0
    /dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
    # Added by KNOPPIX
    /dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
    /dev/hda5 /mnt/hda5 vfat noauto,users,exec,umask=000 0 0
    /dev/hda6 /mnt/hda6 vfat noauto,users,exec,umask=000 0 0
    /dev/hda7 /mnt/hda7 vfat noauto,users,exec,umask=000 0 0
    /dev/hda8 /mnt/hda8 vfat noauto,users,exec,umask=000 0 0
    /dev/hda9 /mnt/hda9 ext3 noauto,users,exec 0 0
    
     
Thread Status:
Not open for further replies.

Share This Page