403 for Joomla,xoops on Apache localhost

Discussion in 'Open Source' started by desertwind, Feb 6, 2006.

Thread Status:
Not open for further replies.
  1. desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    Off late, I was trying to install Joomla and xoops locally. I've Apache 2.0.24 and MySQL 4.1.16 with php 5.0.4 running on my FC4 box.

    Both xoops and Joomla is giving an Error 403 while trying to access using my browser. I'ce set file permissions correct. Is there anything i forgot ?

    Both are working (the same uploaded) perfectly on my hosting server.
    I'm managing a few sites locally, they are woking too.

    This is the error, for referance.
     
  2. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    None to help me ?

    I feel its a very basic thing that i forgot. Can anyone remind me ?
     
  3. GNUrag

    GNUrag FooBar Guy

    Joined:
    Jun 22, 2004
    Messages:
    1,246
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Interwebs
    Code:
    Alias /xoops "/usr/share/xoops/"
    <Directory "/use/share/xoops/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order allow,deny
            Allow from all
    </Directory>
    
    This should remove your access denied errors, additionally make sure that the directory in concern is readable by Apache2.
     
  4. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    I was wondering why GNURag is not answering me. Well, thanks.

    I tried that one already, but still giving the same 403.
     
  5. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    Well now I have known how to configure a webserver and aliases after extreme difficulties...It seems u have not set the permissions correct...Try to set the permission of the whole path of "/xoops" with 755 and files in that too!
    If u have created another username like "/home/user"..tjhen u need to do "chmod 755 /home/user"!
     
  6. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    I've set all file permissions correct. I don't know whats wrong.
     
  7. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    Tell me everythin how u tried to access it and on what port and n what ip (locally->127.0.0.1)? I think i can help ya! Have u tried the defaults?
     
  8. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    I've setup Apache (really long time ago, no problems yet). I usually store my local websites on /var/www/html/ (Which, ofcourse is apache DirectoryIndex). Everything was working fine. So i tried to install Joomla on my PC, so that after customising all the stuff, i can upload it to my website.

    i place it on /var/www/html/Joomla, and tried it accessing by pointing my browser to
    http://localhost/Joomla , which gave me a Error 403.

    So i checked for file permissions, and found everything was 755. I run an additional

    chmod -R 755 Joomla/

    But still the problem persits. Then i tried moving the directory to inside one of my working folder, bitz.

    http://localhost/bitz is working, but
    http://localhost/bitz/Joomla is not.

    Some three days back I downloaded xoops, followed the same procedure, and got the same error.

    Both Joomla and xoops are working remotely, when uploaded to my site.
     
  9. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    Problem Solved!!!

    It was an issue with SELinux.

    Just run the following as root

    Code:
    chcon -R -t httpd_sys_content_t /var/www/html/
    And it was solved.
     
  10. praka123

    praka123 left this forum longback

    Joined:
    Sep 7, 2005
    Messages:
    7,513
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    -
    So SELINUX restrictions and values should be known before configuring any network services controlled by selinux.. :( .in my computer institute they disable selinux during install itself..
     
  11. OP
    OP
    desertwind

    desertwind New Member

    Joined:
    Nov 2, 2004
    Messages:
    1,096
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Hyderabad
    Thats what everyone's doing. They simply disale selinux. Because it's such a headache. BTW, It's a part of improved Security.
     
  12. mediator

    mediator New Member

    Joined:
    Mar 18, 2005
    Messages:
    2,491
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    In ur Evil Mind!
    Yea i too configured the selinux for aliases to work and create the web server !!!
     
Thread Status:
Not open for further replies.

Share This Page