WiFi Problem in Windows 8 PRO in Lenovo Z580

Discussion in 'Laptops and Netbooks' started by DirectX, Mar 4, 2013.

  1. DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    Hi, I'm currently using Lenovo Z580 Laptop which had a Pre-installed Genuine Windows 7 Home Basic OS when I bought it in September, 2012. But, I have upgraded it to Windows 8 PRO online using my internet connection on its launching date. But from near about 30 days ago, I'm experiencing an unexpected problem taking the WiFi Connectivity.

    After connecting to my WiFi, generated by my D-Link DIR-615 Wireless N300 Router with the mixed type broadcasting 802.11b/g/n the pinging reply from my ISP's IP (For me, it's 172.24.1.1) was just being seemed to be abnormal to me. The pinging reply used to show about 6ms, 2ms, 3ms response time but suddenly it transformed into 12 - 15 Request Timed Out constantly. Or, sometimes, it used to to display 3 to 8 Request Timed Out dialogue just after showing 2 to 3 short response times like mentioned before!

    Another problem is that, even if I get fixed and steady replies from my ISP's server, Firefox sometimes doesn't respond properly. I'm currently using FireFTP to transfer files between my Lappy and FTP Servers. But, sometimes after uploading a few MBs of a file, transmission stops and even I also can not browse web then. But, still then I can see the response time in PING nearly about 2ms to 4ms with great steadiness! But, in order to browse again, I had to disconnect and Reconnect to the WiFi again.

    Now, I'm also facing another problem. After connecting to my WiFi, it's also displaying Reply From: 192.168.0.1: Destination Host Unreachable after 2 to 3 minutes of successful pinging replies from my ISP's hosting IP: 172.24.1.1. 192.168.0.1 is my Router's IP and by putting this IP I can visit my router's configuration home page.

    Some days before such critical faults were noted, I also found some abnormal behavior from my Lappy's WiFi. It used to show the Connected WiFi icon in the Lock Screen just after the completion of Booting (Even before signing in to my Local Account). And, normally I then used to sign in and go to desktop from the start screen. My Kaspersky Internet Security 2013 always takes too much time to launch and usually activates its protection after the start ups of all the auto start apps. But, after a few minutes, my WiFi used to get disconnected automatically! If, I try to reconnect, then it shows Unable to connect dialogue! After performing these steps again and again, it even used to stop displaying the SSID of the WiFi Signal! Then I had to go the the Adapter Settings and then disable and re-enable the WiFi Adapter.

    I'm still facing all of these problems even on today! Please help me.

    Thanks.
     
  2. pratyush997

    pratyush997 Inactive

    Joined:
    Mar 25, 2012
    Messages:
    3,763
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Earth
    Reinstall Drivers
    BTW I faced similar issues on my HP PAvilion tx 1000 // which is dead now :p
    BTW did you checked whether there is noting wrong with the router?
     
  3. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    Thanks pratyush997 bro.
    I had re-installed drivers twice! But nothing happened! :cry:
    Router is responding perfectly. I've checked it and PINGed its address too (192.168.0.1). It was providing replies sometimes even less than 1ms and with great great great steadiness!
     
  4. pratyush997

    pratyush997 Inactive

    Joined:
    Mar 25, 2012
    Messages:
    3,763
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Earth
    you got Droid mobile?
    Connect it to wifi and check!
     
  5. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
    Exactly the same problem i was facing a few days ago: http://www.thinkdigit.com/forum/networking/169914-wifi-get-conected-but-only-10-sec.html

    i did re-installations of drivers many times, that did'nt helped at all..
    what i found out was that the problem arose only after the laptop waking up from hibernation, sleep, or idle for long hrs. Even while downloading large files through IDM, connection used to reset itself disrupting the download in progress. Restarting the laptop usually used to resolve my problem, what i did is that i now don't put my laptop into hibernation that much, updated my router firmware as well as wifi drivers, in wifi settings ticked the option of "Enable Intel Connection Settings", in Power Management options unticked the option of "allow computer to turn off device", and now everything is working fine for past 2-3 weeks, though i still see some disconnections from wifi, but they are rare now, once in 3-4 days, but it's bearable now.. :p It's windows 8 problem, coz i used to get perfectly OK signals in windows 7..
    Here's what now i get when i ping the gateway (i am currently sitting two rooms away from my router with 2 walls in between, almost 25-30 meters away):
    [​IMG]
     
  6. s18000rpm

    s18000rpm ಠ_ಠ

    Joined:
    Mar 1, 2006
    Messages:
    5,607
    Likes Received:
    87
    Trophy Points:
    48
  7. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
  8. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    @Pratyush997 bro, Yes. I have. But, when I'm using its Portable WiFi Hotspot, Laptop seems to be working normally!

    I have now set my WiFi Networks to "Trusted Network" zone. Let's see what happens!
    Thanks a lot, Ratul bro and s18000rpm bro.
    :smile:

    I am also facing some problem in its Bluetooth too. My laptop was packed with Bluetooth 4.0 Hardware and It was working very fine in High Speed mode (Tested on Bluetooth 3.0) when my laptop had the Windows 7 Home Basic. But after upgrading to Windows 8 PRO and even after Installing the Officially Released drivers for my laptop with Windows 8 x64 OS as displayed in the Lenovo India Website, I'm not getting the speed of High Speed Bluetooth 3.0 or Bluetooth 4.0 while transferring files to other smartphones or devices, packed with Bluetooth 3.0 or Bluetooth 4.0. But, I used to get such speed when I had Windows 7 Home Basic with Pre-Installed Drivers. Watching this, I had Installed Bluesoleil 10 (Cracked) that supports Bluetooth 4.0. But, I was just unable to use it as the previous official driver was still active! I then Uninstalled the Official Driver from Control Panel's Programs and Features option and Rebooted my Lappy! But, after doing that, I found Microsoft's very own Bluetooth Driver has arrived in its place and again Bluesoleil 10 was inactive. I tried a lot to activate Bluetooth on Bluesoleil 10 but, nothing happened! Here is the link of Bluesoleil 10 that I had Installed! Please help me to resolve this problem too.

    Thanks.
     
  9. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
    make sure you have both bluetooth driver as well as Bluetooth+High speed like shown:
    [​IMG]
    The high speed one supports 4.0 speeds and is installed with the wifi drivers rather than with bluetooth drivers..
     
  10. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    Screenshot (23).png
    I only have these Intel Drivers. What should I do now?
     
  11. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
    look in Control Panel>Programs>Uninstall a Program.
     
  12. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    I found that, there are only these Intel Drivers. What should I do now, Ratul bro?
    [​IMG]
     
  13. .jRay.

    .jRay. New Member

    Joined:
    May 8, 2012
    Messages:
    831
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Mumbai
    I too have a z580 with windows8pro but I never faced any of these issues , I upgraded in November
     
  14. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
    i can't see the bluetooth drivers anywhere, first install the bluetooth drivers, and then wifi drivers, which should contain BT High speed drivers..
    My 15R Turbo has a Centrino N-2230 wireless drivers, so High Speed drivers comes with that package only..
     
  15. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    How did you upgrade nickaustin bro? Did you use Windows Upgrade Assistant to upgrade the Windows 7 Home Basic or fully formatted the C: Drive and then booted using the iso that you had downloaded from the Windows Upgrade Assistant while purchasing it online?

    Screenshot (24).png

    Here is the only Bluetooth driver that appeared into the Programs List after installing the Bluetooth Driver for Windows 8 x64 from the Official Lenovo India Website, Ratul bro.
     
    Last edited: Mar 4, 2013
  16. ratul

    ratul IT Security Enthusiast

    Joined:
    Aug 27, 2011
    Messages:
    1,268
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Delhi, India.
    As you have Broadcom chip, which i think has to have inbuilt 4.0 support (i think Enhanced data rate implies that), i can't help you anymore, coz broadcom drivers are different from intel bluetooth drivers, which my lappy has.. :(
    let's see what nickaustin has to say about this problem..
     
  17. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    No problem, Ratul bro. You've tried your best to help me and I'm really thankful to you for this. :)

    Let's see what nickaustin bro says about my Bluetooth problem.
     
  18. s18000rpm

    s18000rpm ಠ_ಠ

    Joined:
    Mar 1, 2006
    Messages:
    5,607
    Likes Received:
    87
    Trophy Points:
    48
  19. OP
    DirectX

    DirectX New Member

    Joined:
    Apr 1, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West Bengal, India.
    I think, when I tried to install these chipset drivers, it was displayed that these drivers are not supported on my system and at that moment, I was just unable to install these. Even the Bluetooth also showed the same problem then. But, nearly about one month ago, I re-downloaded the Bluetooth drivers and it then installed successfully. But, I hadn't tried these chipset drivers after then. Thanks for reminding me about it. I'm currently downloading the chipset drivers. Let me check what happens.

    Thanks a lot for your guidance. :)

    I'll be back shortly.
     
    Last edited: Mar 5, 2013
  20. s18000rpm

    s18000rpm ಠ_ಠ

    Joined:
    Mar 1, 2006
    Messages:
    5,607
    Likes Received:
    87
    Trophy Points:
    48
    also, update Windows 8.
     

Share This Page